Natenoms Wiki

Weil Teilen Spaß macht :)

Benutzer-Werkzeuge

Webseiten-Werkzeuge


Seitenleiste

Übersetzungen dieser Seite:

Navigation



Lizenz dieses Wikis
Über dieses Wiki
Feed des Wikis
Impressum


Was gerade in meinem Blog geschieht:

mumble:entwicklung:feature_requests:bughunting

Bughunting

PulseAudio

Nicht immer wird ein Ausgabekanal für PulseAudio erstellt…

PulseAudio Output bug.
Ausgabe geht nicht: https://paste.kde.org/489776/
Ausgabe geht: https://paste.kde.org/489764/, https://paste.kde.org/489776/
https://sourceforge.net/tracker/index.php?func=detail&aid=3414882&group_id=147372&atid=768005
https://sourceforge.net/tracker/?func=detail&aid=3196110&group_id=147372&atid=768005

Ploppen bei Sendebeginn

Erledigt: Sehr lange Verbindungszeit zum Server

Verbindung zu einem Server dauert sehr lange; dabei ist der Vorgang CPU-Lastig, Netzdaten werden kaum übertragen. (ist der Vergleich der Hash-Werte der einzelnen Kanäle so CPU intensiv?)

GELÖST :) Die Datenbankzugriffe auf dem Client wurden optimiert, dauert nun ca. 160ms :) Siehe hier und hier.

Video

  • Unter Windows ist es nicht CPU lastig, da dauert es einfach nur sehr lange.
  • Hier ein Video dazu, es läuft überall ausser Opera direkt im Browser:
    slow.ogv
    Links läuft der aktuelle Snapshot (ca. 20 Sekunden Verbindungszeit) und rechts Mumble 1.2.1 (Verbindungszeit 2-3 Sekunden). Mit 1.2.2 ist es auch schnell.
  • Hier ein aktuelles Video (2010-10-13) mit dem aktuellen Git in Linux: sc.ogv

Ubuntu

Selbst unter dem aktuellen Ubuntu PPA Paket von Mumble 1.2.2 gibt es das Problem:

  • beim ersten Verbinden sehr schnell
  • wenn man dann aber sämtliche Kommentare (auf unserem Server in fast jedem Kanal :P bei ca. 170 Kanälen) einmal anklickt und dann neu verbindet, dauert es auch hier statt vorher instant ca. 4-6 Sekunden.

Getestet

  • Datenbank lokal gespiegelt und getestet, dauert genauso lange, hat also nichts mit dem Netzwerk zu tun.
  • Frische Datenbank für Mumble-Client: beim ersten Connect instant, sobald man alle Kanäle angeklickt hat wieder ewig.
  • Server seitig alle Kommentare entfernt: Connect instant.
    • später Sortierreihenfolge geändert: weiterhin instant.
  • oprofile stürzt auf meinem System leider ab mit Segfault
  • Alle Kommentare aus dem Server entfernen („DELETE FROM channel_info;“): instant

CPU-Belastung

  • auf meinem System beim Verbinden 4-9 Prozent, beim Anzeigen der Welcomemessage kurzzeitig 29 %

Es ist anscheinend egal wie viele Kanäle, selbst mit 187 ohne Kommentare ist es instant, mit Kommentaren dauert es dann erst wieder ewig.

mumble/entwicklung/feature_requests/bughunting.txt · Zuletzt geändert: 2015/11/26 18:13 von Natenom